RHS Feedback

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005635USAFGeneralpublic2020-05-01 10:142020-05-01 22:16
Reporteralexkoepp 
Assigned Toreyhard 
PrioritynoneSeverityminorReproducibilitysometimes
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version0.5.1 
Summary0005635: Apache gunner laser turns on automatically
DescriptionMy buddy and I were trying to figure out how all the missiles work and kept running into this problem. A target is laser designated by a third party. Gunner fires a LOAL missile to hit the target, but the Apache laser turns on instantly, causing missiles to not know which laser to follow.
Steps To ReproduceHappens pretty consistently, most of the time when the gunner fires a missile the Apache laser designator turns on automatically, making teamwork more difficult. Does not seem to happen every time but I can't root out the exact circumstances, but it turns on more often than not it seems.
Additional Informationhttps://youtu.be/A0rHL7nuARo [^]

Maybe this is purposeful, I'm not sure. I feel like if I want to use the Apache designator, I will turn it on. If I don't want it on, I don't want it to turn on when a missile is fired. A workaround seems to be that when the missile is fired and it switches the laser on, to turn it off IMMEDIATELY. I then get consistant results, but your gunner has to realize it happened and correct it almost instantaneously.
TagsNo tags attached.
Is it a wish/request?No
RHS versionStable
Arma 3 version1.96
Did you used any other mod when the error occurred?No
Which mods?
Attached Files

- Relationships

-  Notes
(0010578)
reyhard (administrator)
2020-05-01 11:09

Your buddy is on pilot seat, right?
(0010579)
alexkoepp (reporter)
2020-05-01 11:16

in the video yes, we swapped seats and it happened to both of us
(0010580)
reyhard (administrator)
2020-05-01 17:28

There was some wrong locality check for LOAL LO & HI which detected gunner as AI. In this case, laser is auto engaged so I guess that was the culprit. Tried it quickly on local server and it seems to work after small fix
(0010582)
alexkoepp (reporter)
2020-05-01 22:16

Cool man, thanks! I appreciate all the hard work you guys do

- Issue History
Date Modified Username Field Change
2020-05-01 10:14 alexkoepp New Issue
2020-05-01 11:09 reyhard Note Added: 0010578
2020-05-01 11:09 reyhard Assigned To => reyhard
2020-05-01 11:09 reyhard Status new => feedback
2020-05-01 11:16 alexkoepp Note Added: 0010579
2020-05-01 11:16 alexkoepp Status feedback => new
2020-05-01 17:28 reyhard Note Added: 0010580
2020-05-01 17:28 reyhard Status new => resolved
2020-05-01 17:28 reyhard Fixed in Version => 0.5.1
2020-05-01 17:28 reyhard Resolution open => fixed
2020-05-01 22:16 alexkoepp Note Added: 0010582


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker