RHS Feedback

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003369USAF[All Projects] Generalpublic2017-06-21 12:412017-09-25 21:13
Reportertriky 
Assigned Toreyhard 
PrioritynoneSeveritymajorReproducibilityhave not tried
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version0.4.3 
Summary0003369: M113 huge RPT spam
Descriptionwhen placing a rhsusf_m113d_usarmy in a mission on dedicated server it start to spam this message on RPT

NetServer: trying to send too large non-guaranteed message (1360 bytes long, max 1348 allowed)
Message not sent - error 0, message ID = ffffffff, to 435978474 (triky)

repeated a lot of time per second and for every connected client, even the headless client
'cause of that log files grows very fast (>100 mb/hour, depending how many users are connected)

this behavior started after 1.70 and never seen before
Steps To Reproduceput a rhsusf_m113d_usarmy on a mission, run on a dedi server amd check the RPT
Additional Informationput a rhsusf_m113d_usarmy on a mission, run on a dedi server amd check the RPT
TagsNo tags attached.
Is it a wish/request?No
Arma 3 version1.70
Did you used any other mod when the error occurred?No
Which mods?
Attached Filestxt file icon log.txt [^] (73,539 bytes) 2017-06-21 16:14 [Show Content]
? file icon arma3server_x64_2017-09-25_20-09-50.rpt [^] (94,585 bytes) 2017-09-25 20:40
? file icon arma3_x64_2017-09-25_20-09-49.rpt [^] (95,365 bytes) 2017-09-25 20:40

- Relationships

-  Notes
(0006322)
reyhard (administrator)
2017-06-21 15:15
edited on: 2017-06-21 15:15

could you upload that .rpt, please?

(0006413)
Sparfell_19 (reporter)
2017-08-09 17:16

Same issue on my side. Removing the M113 RHS solved it. I can provide a rpt but I didn't try with rhs alone, I had a lot of other mods running. So a conflict with another mod is still possible.
https://pastebin.com/Ah4dUSYV [^] (I removed some identical lines in order to make it lighter)
(0006446)
j0zh94 (developer)
2017-08-24 20:48

Upon testing error appears when CBA+RHS is used but no error with RHS alone. This will have to be pushed to the CBA team to resolve.
(0006449)
BlackHawk (reporter)
2017-08-25 12:11

I reproduced the error with vanilla+RHS. From my testing it turns out that CBA doesn't seem to affect anything. Source of confusion appears to be fact that errors start only after some delay (around 1 minute).

Error appears for whoever vehicle is local to.
Medical variant doesn't produce the error.
After deleting vehicle, error disappears.

Repro steps:
1. Use Eden to make a mission with vanilla NATO rifleman and rhsusf_m113d_usarmy.
2. Host a dedicated server with only RHS (GREF, ARF, USAF).
3. Join the server, start a mission and WAIT (1 minute or so).
4. Notice RPT growing in size.
5. Delete M113 - error gone.

Server RPT:
https://pastebin.com/fr06a0rE [^]

Client RPT:
https://pastebin.com/h17Mna9r [^]
(0006450)
BlackHawk (reporter)
2017-08-25 12:30
edited on: 2017-08-25 12:33

Upon further testing it appears that only variants with M2 are affected ("rhsusf_m113d_usarmy", "rhsusf_m113d_usarmy_supply"). Medical, M240 and Mk19 variants are OK.

Error appears also for spawned-in vehicles after some DELAY (again, 1-2 minutes).
Turning simulation off for the vehicle stops errors from generating.

(0006461)
bean7861 (reporter)
2017-08-30 02:16

I believe the community im in has found the same issue, we have had to stop using the M113 in the mean time
(0006493)
reyhard (administrator)
2017-09-11 06:17

Is it still happening with new arma patch?
(0006495)
BlackHawk (reporter)
2017-09-11 09:32

yes
(0006496)
reyhard (administrator)
2017-09-11 11:28

is it same message as before? there were some changes in 1.76 to animation sources and I wonder if it had some impact on it
(0006497)
Dystopian (reporter)
2017-09-11 11:32

absolutely same
(0006498)
reyhard (administrator)
2017-09-11 13:44

is it happening during certain condition? do you have get inside M113 or just empty ones are making that?
(0006499)
BlackHawk (reporter)
2017-09-11 16:04

No special conditions. Both empty and crewed. Note that upon entering the vehicle errors will not be generated for around a minute, then resume again (due to vehicle's locality changing(?)).
(0006502)
reyhard (administrator)
2017-09-12 13:12

is it happening if you remove all weapons & magazines? could you try https://community.bistudio.com/wiki/removeAllWeapons [^] & this https://community.bistudio.com/wiki/removeMagazine [^]
(0006504)
BlackHawk (reporter)
2017-09-13 20:12

'm113 removeWeapon "RHS_M2"' or 'm113 removeMagazines "rhs_mag_100rnd_127x99_mag_Tracer_Red"' stop errors from generating.
(0006505)
reyhard (administrator)
2017-09-13 22:50

that's very interesting! could you do tests with removal of just weapon & then just magazine separately?
(0006509)
BlackHawk (reporter)
2017-09-15 16:52

It's definitely related to vehicle magazines. If I run ' m113 setVehicleAmmoDef 0.9 ' errors stop, but if I run that command with value of 1 they resume immediately. Removing one magazine somehow fixes it... Note that "removing" a magazine by shooting it doesn't do anything.
(0006521)
reyhard (administrator)
2017-09-25 19:11

http://reyhard.armacenter.pl/arma3/rhsusf_c_m113.rar [^] could you test if it's still happening with this pbo? If yes, I will remove another magazine
(0006523)
BlackHawk (reporter)
2017-09-25 20:39

Thank you reyhard, this pbo fixes the problem.
However, there's many new errors in rpt, especially `No entry 'bin\config.bin/CfgWeapons.rhsusf_weap_DummyLauncher'.` which prevents mission from loading on first try. I was using clean mission with vanilla NATO soldier and a M113 and nothing else. I'm attaching client and server RPTs.
(0006524)
reyhard (administrator)
2017-09-25 21:13
edited on: 2017-09-25 21:13

yeah, it's fine. I didn't send you whole update after all - that's why you get some errors about missing things ;)


- Issue History
Date Modified Username Field Change
2017-06-21 12:41 triky New Issue
2017-06-21 15:15 reyhard Note Added: 0006322
2017-06-21 15:15 reyhard Assigned To => reyhard
2017-06-21 15:15 reyhard Status new => feedback
2017-06-21 15:15 reyhard Note Edited: 0006322 View Revisions
2017-06-21 16:14 triky File Added: log.txt
2017-08-09 17:16 Sparfell_19 Note Added: 0006413
2017-08-24 20:48 j0zh94 Note Added: 0006446
2017-08-25 12:11 BlackHawk Note Added: 0006449
2017-08-25 12:30 BlackHawk Note Added: 0006450
2017-08-25 12:33 BlackHawk Note Edited: 0006450 View Revisions
2017-08-30 02:16 bean7861 Note Added: 0006461
2017-09-10 23:40 Dystopian Status feedback => new
2017-09-11 06:17 reyhard Note Added: 0006493
2017-09-11 06:17 reyhard Status new => feedback
2017-09-11 09:32 BlackHawk Note Added: 0006495
2017-09-11 11:02 Dystopian Status feedback => new
2017-09-11 11:28 reyhard Note Added: 0006496
2017-09-11 11:28 reyhard Status new => feedback
2017-09-11 11:32 Dystopian Note Added: 0006497
2017-09-11 11:36 Dystopian Status feedback => new
2017-09-11 13:44 reyhard Note Added: 0006498
2017-09-11 13:44 reyhard Status new => feedback
2017-09-11 16:04 BlackHawk Note Added: 0006499
2017-09-11 16:20 Dystopian Status feedback => new
2017-09-12 13:12 reyhard Note Added: 0006502
2017-09-12 13:12 reyhard Status new => feedback
2017-09-13 20:12 BlackHawk Note Added: 0006504
2017-09-13 22:50 reyhard Note Added: 0006505
2017-09-15 16:52 BlackHawk Note Added: 0006509
2017-09-25 09:27 Dystopian Status feedback => new
2017-09-25 19:11 reyhard Note Added: 0006521
2017-09-25 19:11 reyhard Status new => feedback
2017-09-25 20:39 BlackHawk Note Added: 0006523
2017-09-25 20:40 BlackHawk File Added: arma3server_x64_2017-09-25_20-09-50.rpt
2017-09-25 20:40 BlackHawk File Added: arma3_x64_2017-09-25_20-09-49.rpt
2017-09-25 21:13 reyhard Note Added: 0006524
2017-09-25 21:13 reyhard Status feedback => resolved
2017-09-25 21:13 reyhard Fixed in Version => 0.4.3
2017-09-25 21:13 reyhard Resolution open => fixed
2017-09-25 21:13 reyhard Note Edited: 0006524 View Revisions


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker