RHS Feedback - USAF
View Issue Details
0001280USAF[All Projects] Generalpublic2015-10-13 15:592015-10-14 14:52
MADBUG 
PuFu 
noneminorN/A
closedsuspended 
 
 
No
1.52
No
0001280: Weird HMMWV HitPoints and Wheels parts names
Weird HMMWV HitPoints and Wheels parts names comparasing to other vehicles.
BTR-60:
class HitRFWheel: HitRFWheel
            {
                armor=0.34999999;
                name="wheel_2_1_steering";
                passThrough=0.1;
                explosionShielding=0.89999998;
            };
class RF: LF
            {
                boneName="wheel_2_1_damper";
                center="wheel_2_1_axis";
                boundary="wheel_2_1_bound";
                suspForceAppPointOffset="wheel_2_1_axis";
                tireForceAppPointOffset="wheel_2_1_axis";
                steering=1;
                side="right";
            };
HMMWV:
class HitRFWheel
            {
                armor=0.25;
                material=-1;
                name="wheel_2";
                visual="";
                passThrough=0.30000001;
            };
class RF: LF
            {
                boneName="wheel_2_1_damper";
                center="axis_wheel_2_1";
                boundary="bound_wheel_2_1";
                suspForceAppPointOffset="axis_wheel_2_1";
                tireForceAppPointOffset="axis_wheel_2_1";
                steering=1;
                side="right";
            };
looks like this also doesn't allow for ACE3 repair module add proper repair functioning for HMMWV
No tags attached.
Issue History
2015-10-13 15:59MADBUGNew Issue
2015-10-13 16:42PuFuNote Added: 0002574
2015-10-13 17:24MADBUGNote Added: 0002575
2015-10-13 17:36PuFuNote Added: 0002576
2015-10-13 23:58MADBUGNote Added: 0002578
2015-10-14 00:01MADBUGNote Edited: 0002578bug_revision_view_page.php?bugnote_id=2578#r1138
2015-10-14 00:02MADBUGNote Edited: 0002578bug_revision_view_page.php?bugnote_id=2578#r1139
2015-10-14 14:52PuFuNote Added: 0002587
2015-10-14 14:52PuFuStatusnew => closed
2015-10-14 14:52PuFuAssigned To => PuFu
2015-10-14 14:52PuFuResolutionopen => suspended

Notes
(0002574)
PuFu   
2015-10-13 16:42   
what do you mean by weird? define weird when it comes to bone names...
(0002575)
MADBUG   
2015-10-13 17:24   
Weird may be not the right word but it looks different from others vehicles.
Also this looks like a strange decision in naming:
class RR: RF
            {
                boneName="wheel_2_2_damper";
                steering=0;
                center="axis_wheel_4_1";
                boundary="bound_wheel_4_1";
                suspForceAppPointOffset="axis_wheel_4_1";
                tireForceAppPointOffset="axis_wheel_4_1";
                maxHandBrakeTorque=30000;
            };
(0002576)
PuFu   
2015-10-13 17:36   
what precisely? The class names, the bone names, the memory points?
Can you precisely say how and what of the above would need to be renamed in order for a 3rd party mod to correctly work with RHS?
(0002578)
MADBUG   
2015-10-13 23:58   
(edited on: 2015-10-14 00:02)
I can't say that it is going to fix a problem with 3rd party mod but it should remove problem in comparing hit points and wheels points. Name in a hit class and bone name should be like wheel_x_y_*. And center, boundary, etc should be named in similar way and don't have different numbers in names.

I am going try to find a certain point in configs that causing problems, but for now look at it as a tweak request

(0002587)
PuFu   
2015-10-14 14:52   
maybe so.

The idea is as follow - while i agree with following a proper coherent and consequent naming convention, unless there is a "how to" do it that specify what the 3rd party script is looking for in a model, this sort of tweak is bellow the priority list, because from where we are standing this works for it's scope.

If we ever find a reason to change it besides being compatible (it what sense it seems you can't tell) with 3rd party, we will. Until then we won't.