RHS Feedback

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005713USAFGeneralpublic2020-05-20 02:362020-07-26 16:15
ReporterAebian 
Assigned Toreyhard 
PrioritynoneSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version0.5.3 
Summary0005713: M1126 is not able to carry 1 + 8 Men in the back
DescriptionI have placed down an M1126 in the editor, put two vehicle crews in.
Driver + Vehicle Commander.

I then created a Rifle Squad consisting of 1 Squad Leader and 8 Soldiers.
When ever I start the mission one of the Soldiers is instantly ejected and walks behind the Stryker.

If I put him back into the vehicle with 3DEN another person gets ejected.
According to https://www.globalsecurity.org/military/library/policy/army/fm/3-21-11/c01.htm [^] and many other sites the standard US Army rifle squad fits perfectly into the M1126.


Vehicle in Editor (Marksman is last member): https://secure.aebian.org/public/games/107410_20200520023507_1.png [^]


Got three Strykers with the same rifle squad, always the last man gets ejected and then walks with the Stryker:
https://secure.aebian.org/public/games/107410_20200520023721_1.png [^]


Steps To Reproduce1.) Open Editor
2.) Place down M1126
3.) Fill in a US Army Rifle Squad of 1 + 8 Men into the M1126
4.) Start the mission
Additional InformationIf I use fewer men like on my weapons squad (1 + 6 Men) then this issue does not occur.
TagsNo tags attached.
Is it a wish/request?No
RHS versionDevelopment
Arma 3 version1.96
Did you used any other mod when the error occurred?No
Which mods?
Attached Files

- Relationships
related to 0005772resolvedreyhard GREF UH-1H NPC Pilots will kick out 1 passanger from fully loaded helicopter 

-  Notes
(0010724)
reyhard (administrator)
2020-05-20 08:24

it's quite weird because it only happens if you put those troops in eden. Try to put group of soldiers without putting them inside striker and you will see that they are all boarding vehicle correctly. Perhaps it's some Eden bug
(0010725)
Aebian (reporter)
2020-05-20 10:19

@reyhard: You are right, when moving the rifle squad out of the vehicle so that they board on mission start all members get in just fine.

What also weird is, that my weapons squad which has two men less does not have this issue. On mission start even when placed in 3DEN the crew is complete in the vehicle and no one dismounts.

I probably look into this deeper after work
(0010727)
Aebian (reporter)
2020-05-20 22:54

I tested this now extensively but didn't change anything at all on my side.

It seems like no rifle squad member dismounts anymore.
However:

- When fully loaded the Stryker does not move. Neither via 3DEN waypoint nor via ZEUS.

- When the rifle squad first needs to board the Stryker everything works fine.
(0010886)
reyhard (administrator)
2020-07-26 16:15

Fixed it - keep in mind that you will have to put in group again in editor to feel that fix. Previously created missions will still have that weird behavior.

"- When fully loaded the Stryker does not move. Neither via 3DEN waypoint nor via ZEUS." this is sort of Arma bug.
http://feedback.rhsmods.org/view.php?id=5795 [^]

- Issue History
Date Modified Username Field Change
2020-05-20 02:36 Aebian New Issue
2020-05-20 08:24 reyhard Note Added: 0010724
2020-05-20 08:24 reyhard Assigned To => reyhard
2020-05-20 08:24 reyhard Status new => acknowledged
2020-05-20 10:19 Aebian Note Added: 0010725
2020-05-20 22:54 Aebian Note Added: 0010727
2020-06-27 09:34 reyhard Relationship added related to 0005772
2020-07-26 16:15 reyhard Note Added: 0010886
2020-07-26 16:15 reyhard Status acknowledged => resolved
2020-07-26 16:15 reyhard Fixed in Version => 0.5.3
2020-07-26 16:15 reyhard Resolution open => fixed


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker