RHS Feedback

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003925AFRF[All Projects] Generalpublic2018-01-19 10:002018-01-23 09:37
ReporterSputnik Monroe 
Assigned Toreyhard 
PrioritynoneSeveritymajorReproducibilityalways
StatusfeedbackResolutionopen 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0003925: BMD-1 fishtails and moves very erratically when driven by AI
DescriptionThe BMD-1 while moving swerves back and forth non stop while moving when driven by AI. It also seems to erratically slow down and speed up in addition to the swerving.
Steps To ReproducePlace a BMD-1 on a road, give it a move way point, set behavior to safe. Spectate in single player.
Additional InformationI only tested the BMD-1 with this issue, but I imagine the other BMD varient likely suffer the same problem.

Just a theory, but the swerving and slowing and speeding up, could this be caused by the AI over compensating on steering correction and breaking?
TagsNo tags attached.
Is it a wish/request?No
Arma 3 version1.80
Did you used any other mod when the error occurred?No
Which mods?
Attached Filesrar file icon m113 bmd1 example.rar [^] (2,221 bytes) 2018-01-22 07:24

- Relationships

-  Notes
(0007338)
reyhard (administrator)
2018-01-19 10:15

do you have maybe time to test it on devbranch? Some last minute tweaks to PhysX were made with some devbranch changes in mind (refactored steering transfer) but it should influence more player, than AI.

It might be also issue with AI steering PIDs.

Anyway, if I could have another request then please try to include some easy test mission where you can reproduce it everytime so I could quickly take a look at it after work
(0007344)
Sputnik Monroe (reporter)
2018-01-20 01:25

I wont have a lot of time after work tonight, but I can make a quick test mission, since all it requires is one way point. I don't have a dev branch install setup, however if I send a test mission could you load it up and run it in both dev branch and release branch both and see if there is a difference between the two?
(0007360)
reyhard (administrator)
2018-01-21 10:39

I don't have stable version at home so it's hard to test for me. On devbranch it works fine so I'm just curious if it's going to work
(0007377)
Sputnik Monroe (reporter)
2018-01-22 07:25

I've uploaded an example mission on Stratis. I place an M113 on the south of the island an a BMD1 on the north of the island with a few waypoints each.

I'm starting to notice that it happens the worst when the AI is going down hill or when driving on curvy areas.
(0007383)
reyhard (administrator)
2018-01-23 09:37

tried it on stable & on devbranch - seems either some of the new parameters for steering are not working on stable or there were fixes to AI driving on devbranch. I will try to figure out what do with that since it might take a while till next Arma update

- Issue History
Date Modified Username Field Change
2018-01-19 10:00 Sputnik Monroe New Issue
2018-01-19 10:15 reyhard Note Added: 0007338
2018-01-19 10:15 reyhard Assigned To => reyhard
2018-01-19 10:15 reyhard Status new => feedback
2018-01-20 01:25 Sputnik Monroe Note Added: 0007344
2018-01-20 01:25 Sputnik Monroe Status feedback => new
2018-01-21 10:39 reyhard Note Added: 0007360
2018-01-21 10:39 reyhard Status new => feedback
2018-01-22 07:24 Sputnik Monroe File Added: m113 bmd1 example.rar
2018-01-22 07:25 Sputnik Monroe Note Added: 0007377
2018-01-22 07:25 Sputnik Monroe Status feedback => new
2018-01-23 09:37 reyhard Note Added: 0007383
2018-01-23 09:37 reyhard Status new => feedback


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker